Pickelball drills app issues

  • Haven't got my machine yet but.... on D7 and D8 - the BH and FH sequences, the app implies that several balls in the sequences are red (not going over the net). Can someone update the app to modify or do I have to fix that once I have my Titan?



  • Yes, we were aware of the issue and it has now been resolved. Please run the Titan Drills update on the App Store, or in case of android, please download apk from our website https://titanballmachines.com/pages/titan-drills-app-download


  • The app for Android is still messed up.  I changed the height on ball 2 of the FH sequence and it changed the ball simulation to show it going off to the right and dropping short (red).  I didn't change directions, just the height.  The are other examples that just show up where the simulations aren't tracking and will show a red result.  I still show it in the sequence referenced in the above post.  I just redownloaded the app before trying this again and same result.   Please check the simulations again on the Android app.

  • I have been working with tech trying to solve another issue I have been having.  My Android phone connects to the machine fine.  Then I hit a round of balls and go to gather up the balls.  When I pick my phone back up it has disconnected from the machine.  I have to shut my phone all of the way back down and restart the entire phone and reopen the app to get it to reconnect to the machine again.  Almost every time after I hit a round of balls this happens.  Anyone else have this issue?

  • @Lin I believe I have solved the connection issue.  The phone must be set to always allow the connection and not to only allow when using the app.

  • @Titan Support

    I am having the same issue with the simulator showing balls out with the default / stock drill settings. 

    My all seems up to date. App version 1.1.0 from the Apple App Store. Are you sure this was resolved in 1.1.0?

    Let me know if you need additional information or screen shots. 


  • Steve , we have upgraded it to 1.1.2. Please try new version. We did fixed some bugs about simulation .

Please login to reply this topic!